hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daryn Sharp (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-7348) Modify the option of FsShell getmerge from [addnl] to [-nl] for more comprehensive
Date Thu, 09 Jun 2011 14:05:59 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-7348?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13046550#comment-13046550

Daryn Sharp commented on HADOOP-7348:

Please revert {{new CommandFormat(null, 2, 3, "nl");}} to omit the first parameter (null).
 The {{CommandFormat}} ctor that takes the unused parameter has been deprecated, so that's
probably the -1 warning in the QA build.  I'd also recommend moving the -nl to the front of
the usage to be consistent with other commands.  Ie. {{USAGE = "[-nl] <src> <localdst>"}}.

Other than that, looks good!  Just be sure to update the aforementioned tests in hdfs.  Please
link that jira to this one to make it easier to track.

> Modify the option of FsShell getmerge from [addnl] to [-nl] for more comprehensive
> ----------------------------------------------------------------------------------
>                 Key: HADOOP-7348
>                 URL: https://issues.apache.org/jira/browse/HADOOP-7348
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: fs
>    Affects Versions: 0.23.0
>            Reporter: XieXianshan
>            Assignee: XieXianshan
>             Fix For: 0.23.0
>         Attachments: HADOOP-7348.patch, HADOOP-7348.patch_2
> The [addnl] option of FsShell getmerge should be either "true" or "false",but it is very
hard to understand by users, especially  who`s never used this option before. 
> So,the [addnl] option should be changed to [-nl] for more comprehensive.

This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message