hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "gokul [via Hadoop Common]" <ml-node+3016972-1372104908-404...@n3.nabble.com>
Subject Hadoop QuickStart Standalone Operation error
Date Thu, 02 Jun 2011 20:08:12 GMT
Dear all,

I have been trying to get a hang of Hadoop (noob/ newbie). After
installation, I followed the Quick Start guide of Hadoop to execute the
sample example given (
http://hadoop.apache.org/common/docs/r0.20.2/quickstart.html#Local
Standalone Operation ). 
After executing the third step ( $ bin/hadoop jar hadoop-*-examples.jar grep
input output 'dfs[a-z.]+' ), 

I got the error saying that

"Exception in thread "main" java.lang.NoClassDefFoundError:
Internship/hadoop-0/20/2/bin////logs
Caused by: java.lang.ClassNotFoundException:
Internship.hadoop-0.20.2.bin....logs
	at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
Could not find the main class: Internship/hadoop-0.20.2/bin/../logs. Program
will exit."

I tried a lot of different things and nothing worked. 
Some of the solutions that didn't help: 
1) Set the $JAVA_HOME path correctly (works fine)
2) Command incorrect:  $ bin/hadoop jar hadoop-*-examples.jar grep input
output 'dfs[a-z.]+' (correct as per Hadoop QuickStart)


Any form of help is very very gratefully appreciated.

Thanks in advance.



______________________________________
If you reply to this email, your message will be added to the discussion below:
http://hadoop-common.472056.n3.nabble.com/Hadoop-QuickStart-Standalone-Operation-error-tp3016972p3016972.html
This email was sent by gokul (via Nabble)
To receive all replies by email, subscribe to this discussion: http://hadoop-common.472056.n3.nabble.com/template/NamlServlet.jtp?macro=subscribe_by_code&node=3016972&code=Y29tbW9uLWlzc3Vlc0BoYWRvb3AuYXBhY2hlLm9yZ3wzMDE2OTcyfDQyNDMxNTUzOQ==
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message