hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Luke Lu (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-6918) Make metrics naming consistent
Date Thu, 05 May 2011 17:40:03 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-6918?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13029457#comment-13029457
] 

Luke Lu commented on HADOOP-6918:
---------------------------------

Thanks for the comment, Eli, 

The purpose of the jira was to track the proposal/discussion of the changes. I should've commented
that the actual changes will be covered by metrics instrumentation patches in HADOOP-6920,
HDFS-1117 and MAPREDUCE-1738.

> Make metrics naming consistent
> ------------------------------
>
>                 Key: HADOOP-6918
>                 URL: https://issues.apache.org/jira/browse/HADOOP-6918
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: metrics
>    Affects Versions: 0.20.2
>            Reporter: Luke Lu
>            Assignee: Luke Lu
>             Fix For: 0.23.0
>
>
> While working HADOOP-6728, I noticed that our metrics naming style is all over the place:
> * Capitalized camel case: e.g., "FilesCreated" in namenode metrics and some rpc metrics
> * uncapitalized camel case: e.g, "threadsBlocked" in jvm metrics and some rpc metrics
> * lowercased underscored: e.g., "bytes_written" in datanode metrics and mapreduce metrics
> Let's make them consistent. How about uncapitalized camel case? My main reason for the
camel case: some backends have limits on the name length and underscore is wasteful.
> Once we have a consistent naming style we can do:
> @Metric("Number of INodes created") MutableCounterLong filesCreated;
> instead of the more redundant:
> @Metric({"FilesCreated", "Number of INodes created"}) MutableCounterLong filesCreated;

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message