hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matt Foley (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-7236) Refactor FsShell's mkdir
Date Wed, 04 May 2011 16:00:03 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-7236?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13028794#comment-13028794
] 

Matt Foley commented on HADOOP-7236:
------------------------------------

It looks generally good, and this refactoring is very good for the FsShell.

However, I think John George was on the right track when he questioned adding mkdirs(), etc.,
methods to the PathData class.  We seem to already be creating FileContext as a mirror of
all FS methods, we shouldn't do the same with PathData.  To me it seems obvious that the invocation
of mkdirs(), rightly removed from FSCommand, should be located in the Mkdir class.

Daryl and I talked about various ways to try to "simplify the switch to FileContext".  We
concluded (or at least I did -- sorry if I'm putting words in your mouth :-) ) that we were
going through contortions to avoid changing twenty single lines in twenty different files
at some point in the future; i.e., converting the invocations of FileSystem methods to FileContext
methods in each of the implementations of the various FSCommands.  While it would be nice
to avoid that future editing, it isn't worth complicating the design, in my opinion.  And
isn't it kind of the point of all this that each command (or related subset of commands) can
become a separate subclass of FSCommand?  Thanks.

> Refactor FsShell's mkdir
> ------------------------
>
>                 Key: HADOOP-7236
>                 URL: https://issues.apache.org/jira/browse/HADOOP-7236
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: fs
>    Affects Versions: 0.23.0
>            Reporter: Daryn Sharp
>            Assignee: Daryn Sharp
>         Attachments: HADOOP-7236-2.patch, HADOOP-7236.patch
>
>
> Need to refactor tail to conform to new FsCommand class.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message