hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aaron T. Myers (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-7286) Refactor FsShell's du/dus/df
Date Fri, 13 May 2011 18:23:47 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-7286?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13033176#comment-13033176

Aaron T. Myers commented on HADOOP-7286:

Patch looks pretty solid, Daryn. A few comments:

# I think the name "{{Capacity}}" isn't the best. At least in the case of, "{{du}}" and "{{dus}}",
there's no capacity information being calculated - just usage info. I suggest renaming to
something like "{{FsUsage}}". Thoughts?
# Since all sub-classes of {{o.a.h.fs.shell.Capacity}} need a {{TableBuilder}} object, might
as well make this a protected instance variable of {{Capacity}} a la {{humanReadable}}.
# I've always found it silly that we continue to maintain both "{{du}}" and "{{dus}}". Perhaps
now would be a good time to deprecate "{{dus}}" in favor of "{{du -s}}" ? Feel free to say
this should be done as part of a separate JIRA.

> Refactor FsShell's du/dus/df
> ----------------------------
>                 Key: HADOOP-7286
>                 URL: https://issues.apache.org/jira/browse/HADOOP-7286
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: fs
>    Affects Versions: 0.23.0
>            Reporter: Daryn Sharp
>            Assignee: Daryn Sharp
>         Attachments: HADOOP-7286-2.patch, HADOOP-7286.patch
> Need to refactor to conform to FsCommand subclass.

This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message