hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daryn Sharp (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-7286) Refactor FsShell's du/dus/df
Date Fri, 13 May 2011 18:29:47 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-7286?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13033182#comment-13033182
] 

Daryn Sharp commented on HADOOP-7286:
-------------------------------------

All good ideas!  I too dislike all the commands like du/dus that are just permutations of
each other, and would love to get rid of them.  How do you propose "dus" is deprecated?  Writing
something to stderr?  Or just get rid of it?  I'd favor the latter unless there are objections.

> Refactor FsShell's du/dus/df
> ----------------------------
>
>                 Key: HADOOP-7286
>                 URL: https://issues.apache.org/jira/browse/HADOOP-7286
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: fs
>    Affects Versions: 0.23.0
>            Reporter: Daryn Sharp
>            Assignee: Daryn Sharp
>         Attachments: HADOOP-7286-2.patch, HADOOP-7286.patch
>
>
> Need to refactor to conform to FsCommand subclass.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message