hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Suresh Srinivas (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-6920) Metrics2: metrics instrumentation
Date Wed, 11 May 2011 00:17:47 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-6920?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Suresh Srinivas updated HADOOP-6920:

      Resolution: Fixed
    Release Note: 
Metrics names are standardized to use CapitalizedCamelCase. Some examples of this is:
# Metrics names using "_" is changed to new naming scheme. Eg: bytes_written changes to BytesWritten.
# All metrics names start with capitals. Example: threadsBlocked changes to ThreadsBlocked.

    Hadoop Flags: [Incompatible change, Reviewed]
          Status: Resolved  (was: Patch Available)

> Metrics2: metrics instrumentation
> ---------------------------------
>                 Key: HADOOP-6920
>                 URL: https://issues.apache.org/jira/browse/HADOOP-6920
>             Project: Hadoop Common
>          Issue Type: Sub-task
>            Reporter: Luke Lu
>            Assignee: Luke Lu
>             Fix For: 0.23.0
>         Attachments: hadoop-6920-metrics2-inst-v4.patch, hadoop-6920.v6.patch
> The jira tracks the metrics instrumentation for the new framework, i.e., porting jvm
and rpc metrics to the new framework.
> This issue (esp. the "incompatible change flag") depends on the outcome of the discussion
(proposed in HADOOP-6728) on whether we should support backward compatibility (at some cost.)

This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message