hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daryn Sharp (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-7202) Improve Command base class
Date Fri, 25 Mar 2011 15:03:06 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-7202?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Daryn Sharp updated HADOOP-7202:

    Attachment: HADOOP-7202-2.patch

1) I feel that "if (item.exists)" is more intuitive to a reader of external code than "if
(item.stat != null)".  I will change it if you feel strongly.

2) Great idea.

3) I went back and added javadocs links to all my new methods. Phew.

4) I'm trying to more closely follow unix conventions.  Also, -1 for invalid usage versus
1 for execution failure, allows external scripts to differentiate the mode of failure.

5) There are other external commands that subclass Command and will need access to this class
if updated, so I don't think I can reduce the visibility.

> Improve Command base class
> --------------------------
>                 Key: HADOOP-7202
>                 URL: https://issues.apache.org/jira/browse/HADOOP-7202
>             Project: Hadoop Common
>          Issue Type: Improvement
>    Affects Versions: 0.22.0
>            Reporter: Daryn Sharp
>            Assignee: Daryn Sharp
>             Fix For: 0.23.0
>         Attachments: HADOOP-7202-2.patch, HADOOP-7202.patch
> Need to extend the Command base class to allow all command to easily subclass from a
code set of code that correctly handles globs and exit codes.

This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message