hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daryn Sharp (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-7202) Improve Command base class
Date Mon, 21 Mar 2011 18:39:05 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-7202?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Daryn Sharp updated HADOOP-7202:

    Attachment: HADOOP-7202.patch

Add many methods to Command class to facilitate easy overriding for custom behavior.  Add
PathData class to encapsulate a path, fs, and filestatus to avoid passing so many args and/or
multiple lookups during execution.  Modify Count cmd to conform since it was the simplest

(Note: changes in FsShell are temporary, since all the if/then/elses for commands will soon
become a generic call to a command object.)

> Improve Command base class
> --------------------------
>                 Key: HADOOP-7202
>                 URL: https://issues.apache.org/jira/browse/HADOOP-7202
>             Project: Hadoop Common
>          Issue Type: Improvement
>    Affects Versions: 0.22.0
>            Reporter: Daryn Sharp
>            Assignee: Daryn Sharp
>             Fix For: 0.23.0
>         Attachments: HADOOP-7202.patch
> Need to extend the Command base class to allow all command to easily subclass from a
code set of code that correctly handles globs and exit codes.

This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message