hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Allen Wittenauer (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-7083) Allow SecureIO to be disabled for developer workstations
Date Thu, 03 Feb 2011 01:34:29 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-7083?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12989938#comment-12989938
] 

Allen Wittenauer commented on HADOOP-7083:
------------------------------------------

At this point, I'm -1 on this patch.

The more and more I think about it, the more and more I view this as a bad hack that shouldn't
go into the core code.  If SecureIO requires native code, it requires native code. Developers
and users who want to work with Hadoop with the identity features enabled need to work with
it as it is intended to be run.  Otherwise we end up with "it works on my machine!" scenarios.

> Allow SecureIO to be disabled for developer workstations
> --------------------------------------------------------
>
>                 Key: HADOOP-7083
>                 URL: https://issues.apache.org/jira/browse/HADOOP-7083
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: native, security
>    Affects Versions: 0.22.0
>            Reporter: Todd Lipcon
>            Assignee: Alejandro Abdelnur
>         Attachments: hadoop-7083.txt
>
>
> In testing with secure Hadoop, the new requirement for native code is annoying on platforms
like OSX where the native code can be tricky to get compiled and working. We should allow
developers to disable this aspect of security by setting a special flag.

-- 
This message is automatically generated by JIRA.
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message