hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karl Heinz Marbaise (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-7080) Documentation dfs.block.size where dfs.blocksize has to be used instead.
Date Wed, 29 Dec 2010 19:05:48 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-7080?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12975871#action_12975871
] 

Karl Heinz Marbaise commented on HADOOP-7080:
---------------------------------------------

I have first tried to set dfs.block.size in the hdfs-site.xml file and nothing else, cause
i didn't known anything about the new name. I have copied the configuration (hdfs-site.xml)
to all data nodes (only three in my case) and checked that several times. Completely removed
all contents from the HDFS storage and reformatted the namenode (removed also the data directories
from the data nodes).  It doesn't change anything. The files in HDFS used 64 MiB block size
based on the display in the file system  browser (Web-UI). After that i changed the name from
dfs.block.size to dfs.blocksize in the hdfs-site.xml file. And then completely removed things
from cluster etc. and from that point it worked. Now the change of the block size via command
line option like this: 
{{hadoop fs -Ddfs.blocksize=67108864 -copyFromLocal result.log /user/km/tapelogs/logfile-test-64MB.log}}
works.
I tried several time with the following:
{{hadoop fs -Ddfs.block.size=134217728 -copyFromLocal result.log /user/km/tapelogs/logfile-test-64MB.log}}
but this didn't work either. So in my opinion this is not only a documentation bug.


> Documentation dfs.block.size where dfs.blocksize has to be used instead.
> ------------------------------------------------------------------------
>
>                 Key: HADOOP-7080
>                 URL: https://issues.apache.org/jira/browse/HADOOP-7080
>             Project: Hadoop Common
>          Issue Type: Bug
>    Affects Versions: 0.21.0
>         Environment: Linux (Ubuntu)
>            Reporter: Karl Heinz Marbaise
>            Priority: Minor
>
> The configuration for the block size is named *dfs.block.size* in the [documentation
for Release 0.21.0 of Hadoop|http://hadoop.apache.org/common/docs/r0.21.0/cluster_setup.html]
but this will not work nor will it be recognized. If i use [*dfs.blocksize*|http://hadoop.apache.org/hdfs/docs/current/api/constant-values.html]
instead it will work perfectly.  So this seemed to be a documentation bug.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message