hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eli Collins (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-7059) Remove "unused" warning in native code
Date Sun, 12 Dec 2010 02:09:01 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-7059?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12970556#action_12970556
] 

Eli Collins commented on HADOOP-7059:
-------------------------------------

+1

> Remove "unused" warning in native code
> --------------------------------------
>
>                 Key: HADOOP-7059
>                 URL: https://issues.apache.org/jira/browse/HADOOP-7059
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: native
>    Affects Versions: 0.21.0
>            Reporter: Noah Watkins
>         Attachments: HADOOP-7059-1.patch
>
>
> The file:
>    src/native/src/org_apache_hadoop.h
> declares the static function "do_dlsym" in the header as non-inline. Files including
the header (e.g. for the THROW macro) receive a "defined but unused" warning during compilation.
> This function should either a) be inlined or b) use GCC "unused" attribute.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message