hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eli Collins (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-6940) RawLocalFileSystem's markSupported method misnamed markSupport
Date Wed, 08 Sep 2010 23:47:33 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-6940?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12907486#action_12907486
] 

Eli Collins commented on HADOOP-6940:
-------------------------------------

No tests are needed since the behavior stays unchanged. The javadoc warning seems bogus ant
javadoc and javadoc-dev are clean.

{noformat}
     [exec] -1 overall.  
     [exec] 
     [exec]     +1 @author.  The patch does not contain any @author tags.
     [exec] 
     [exec]     -1 tests included.  The patch doesn't appear to include any new or modified
tests.
     [exec]                         Please justify why no new tests are needed for this patch.
     [exec]                         Also please list what manual steps were performed to verify
this patch.
     [exec] 
     [exec]     -1 javadoc.  The javadoc tool appears to have generated 1 warning messages.
     [exec] 
     [exec]     +1 javac.  The applied patch does not increase the total number of javac compiler
warnings.
     [exec] 
     [exec]     +1 findbugs.  The patch does not introduce any new Findbugs warnings.
     [exec] 
     [exec]     +1 release audit.  The applied patch does not increase the total number of
release audit warnings.
     [exec] 
     [exec]     +1 system tests framework.  The patch passed system tests framework compile.
     [exec] 
{noformat}

> RawLocalFileSystem's markSupported method misnamed markSupport
> --------------------------------------------------------------
>
>                 Key: HADOOP-6940
>                 URL: https://issues.apache.org/jira/browse/HADOOP-6940
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: fs
>            Reporter: Tom White
>            Assignee: Tom White
>            Priority: Minor
>         Attachments: HADOOP-6940.patch
>
>
> It should be named markSupported to override the method defined in InputStream. Since
it doesn't change the default no harm is done.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message