hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Luke Lu (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HADOOP-6918) Make metrics naming consistent
Date Mon, 23 Aug 2010 17:28:16 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-6918?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Luke Lu updated HADOOP-6918:
----------------------------

              Summary: Make metrics naming consistent  (was: jjjjjjjjj)
             Assignee: Luke Lu
        Fix Version/s: 0.22.0
                 Tags: metrics
    Affects Version/s: 0.20.2
          Description: 
While working HADOOP-6728, I noticed that our metrics naming style is all over the place:

* Capitalized camel case: e.g., "FilesCreated" in namenode metrics and some rpc metrics
* uncapitalized camel case: e.g, "threadsBlocked" in jvm metrics and some rpc metrics
* lowercased underscored: e.g., "bytes_written" in datanode metrics and mapreduce metrics

Let's make them consistent. How about uncapitalized camel case? My main reason for the camel
case: some backends have limits on the name length and underscore is wasteful.

Once we have a consistent naming style we can do:
@Metric("Number of INodes created") MutableCounterLong filesCreated;

instead of the more redundant:
@Metric({"FilesCreated", "Number of INodes created"}) MutableCounterLong filesCreated;
          Component/s: metrics

> Make metrics naming consistent
> ------------------------------
>
>                 Key: HADOOP-6918
>                 URL: https://issues.apache.org/jira/browse/HADOOP-6918
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: metrics
>    Affects Versions: 0.20.2
>            Reporter: Luke Lu
>            Assignee: Luke Lu
>             Fix For: 0.22.0
>
>
> While working HADOOP-6728, I noticed that our metrics naming style is all over the place:
> * Capitalized camel case: e.g., "FilesCreated" in namenode metrics and some rpc metrics
> * uncapitalized camel case: e.g, "threadsBlocked" in jvm metrics and some rpc metrics
> * lowercased underscored: e.g., "bytes_written" in datanode metrics and mapreduce metrics
> Let's make them consistent. How about uncapitalized camel case? My main reason for the
camel case: some backends have limits on the name length and underscore is wasteful.
> Once we have a consistent naming style we can do:
> @Metric("Number of INodes created") MutableCounterLong filesCreated;
> instead of the more redundant:
> @Metric({"FilesCreated", "Number of INodes created"}) MutableCounterLong filesCreated;

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message