hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Giridharan Kesavan (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HADOOP-6847) Problem staging 0.21.0 artifacts to Apache Nexus Maven Repository
Date Tue, 06 Jul 2010 14:31:50 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-6847?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Giridharan Kesavan updated HADOOP-6847:

    Attachment: hadoop-6847.patch

this patch should fix the issue with uploading artifacts to the nexus maven repo.

command to upload artifact to the staging rep is ;

ant mvn-deploy -Dversion="standard version string" -Drepo=staging

command to upload artifact to the snapshot repo is:

ant mvn-deploy

I 've tried publishing artifacts to the staging repo and it worked.
https://repository.apache.org/index.html#staging;6a441994c87797,  this stating url is not
closed yet for to get a public view. 

> Problem staging 0.21.0 artifacts to Apache Nexus Maven Repository
> -----------------------------------------------------------------
>                 Key: HADOOP-6847
>                 URL: https://issues.apache.org/jira/browse/HADOOP-6847
>             Project: Hadoop Common
>          Issue Type: Bug
>    Affects Versions: 0.21.0
>            Reporter: Tom White
>            Priority: Blocker
>         Attachments: hadoop-6847.patch
> I get this error:
> {noformat}
> -mvn-system-deploy:
> [artifact:install-provider] Installing provider: org.apache.maven.wagon:wagon-http:jar:1.0-beta-2:runtime
> [artifact:deploy] Deploying to https://repository.apache.org/content/repositories/snapshots
> [artifact:deploy] Uploading: org/apache/hadoop/hadoop-common-instrumented/0.21.0/hadoop-common-instrumented-0.21.0.jar
to apache.snapshots.https
> [artifact:deploy] Uploaded 1331K
> [artifact:deploy] An error has occurred while processing the Maven artifact tasks.
> [artifact:deploy]  Diagnosis:
> [artifact:deploy] 
> [artifact:deploy] Error deploying artifact 'org.apache.hadoop:hadoop-common-instrumented:jar':
Error deploying artifact: Failed to transfer file: https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-common-instrumented/0.21.0/hadoop-common-instrumented-0.21.0.jar.
Return code is: 400
> {noformat}
> Note that 400 is "Bad Request", not an authentication error (401).

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message