hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hong Tang (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-3659) Patch to allow hadoop native to compile on Mac OS X
Date Fri, 30 Apr 2010 00:10:57 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-3659?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12862486#action_12862486
] 

Hong Tang commented on HADOOP-3659:
-----------------------------------

Hadoop requires Java 1.6, and on Mac OS X, Java 1.6 only comes with 64-bit version. So there
is really no way to get 32-bit hadoop with native compilation, right?

> Patch to allow hadoop native to compile on Mac OS X
> ---------------------------------------------------
>
>                 Key: HADOOP-3659
>                 URL: https://issues.apache.org/jira/browse/HADOOP-3659
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: native
>    Affects Versions: 0.20.0
>         Environment: Mac OS X 10.5.3
>            Reporter: Colin Evans
>            Assignee: Colin Evans
>            Priority: Minor
>             Fix For: 0.22.0
>
>         Attachments: HADOOP-3659.patch, hadoop-native-mac.patch, hadoop-native-mac.patch
>
>
> This patch makes the autoconf script work on Mac OS X.  LZO needs to be installed (including
the optional shared libraries) for the compile to succeed.  You'll want to regenerate the
configure script using autoconf after applying this patch.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message