hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matt Ahrens (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HADOOP-6345) Refactor Trash::moveToTrash() and its accompanying poor tests
Date Mon, 16 Nov 2009 21:14:39 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-6345?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Matt Ahrens updated HADOOP-6345:

    Affects Version/s: 0.20.1
         Release Note: Changes moveToTrash to only return false when trash is disabled; all
other errors result in IOException.  Added functional unit tests for moveToTrash() to cover
major exit paaths.
         Hadoop Flags: [Incompatible change]
               Status: Patch Available  (was: Open)

> Refactor Trash::moveToTrash() and its accompanying poor tests
> -------------------------------------------------------------
>                 Key: HADOOP-6345
>                 URL: https://issues.apache.org/jira/browse/HADOOP-6345
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: fs
>    Affects Versions: 0.20.1
>            Reporter: Jakob Homan
>         Attachments: HADOOP-6345.patch
> We've had several issues relating to the Trash and its access via the shell, none of
which were picked up by the unit tests.  The current moveToTrash method has 8 different ways
it can terminate and sometimes uses a false value and sometimes uses an exception to indicate
failure.  This method should be refactored to improve readability and testability, and new
tests written to exercise all possible code paths.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message