hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nathan Marz (JIRA)" <j...@apache.org>
Subject [jira] Created: (HADOOP-6298) BytesWritable#getBytes is a bad name that leads to programming mistakes
Date Wed, 07 Oct 2009 22:01:32 GMT
BytesWritable#getBytes is a bad name that leads to programming mistakes
-----------------------------------------------------------------------

                 Key: HADOOP-6298
                 URL: https://issues.apache.org/jira/browse/HADOOP-6298
             Project: Hadoop Common
          Issue Type: Improvement
    Affects Versions: 0.20.1
            Reporter: Nathan Marz


Pretty much everyone at Rapleaf who has worked with Hadoop has misused BytesWritable#getBytes
at some point, not expecting the byte array to be padded. I think we can completely alleviate
these programming mistakes by deprecating and renaming this method (again) to be more descriptive.
I propose "getPaddedBytes()" or "getPaddedValue()". It would also be helpful to have a helper
method "getNonPaddedValue()" that makes a copy into a non-padded byte array. 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message