hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jakob Homan (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-6233) Changes in common to rename the config keys as detailed in HDFS-531.
Date Tue, 08 Sep 2009 21:41:58 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-6233?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12752761#action_12752761

Jakob Homan commented on HADOOP-6233:

Gave the patch a quick look-over:
* The patch has gone stale with the committing of HADOOP-6234.  The config key umask has been
changed to umaskmode and its type is now a string.
* I'm concerned about having all the key changes for all across the project clustered in one
file, and more so that there's a separate file for just the fs.  It seems to me this will
lead to confusion about updating those values or adding new ones.  Might it be better to include
that info in the relevant file?
* In Configuration, the code readability could be improved with a private static function
like addDepKey(keyName, keyValue) that handles all the boiler plate of Configuration.addDeprecation(*,
new String[] { *} ).

> Changes in common to rename the config keys as detailed in HDFS-531.
> --------------------------------------------------------------------
>                 Key: HADOOP-6233
>                 URL: https://issues.apache.org/jira/browse/HADOOP-6233
>             Project: Hadoop Common
>          Issue Type: Improvement
>            Reporter: Jitendra Nath Pandey
>            Assignee: Jitendra Nath Pandey
>             Fix For: 0.21.0
>         Attachments: HADOOP-6233.1.patch, HADOOP-6233.2.patch, HADOOP-6233.3.patch
> This jira tracks the code changes required in common to rename the config keys. The list
of changed keys is attached to HDFS-531.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message