hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hong Tang (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-4819) 0.19.1 will not build under Solaris 5.10 (x86)
Date Fri, 18 Sep 2009 17:50:16 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-4819?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12757292#action_12757292
] 

Hong Tang commented on HADOOP-4819:
-----------------------------------

Or create a issue ticket on hadoop-gpl-compression to help the community?

> 0.19.1 will not build under Solaris 5.10 (x86)
> ----------------------------------------------
>
>                 Key: HADOOP-4819
>                 URL: https://issues.apache.org/jira/browse/HADOOP-4819
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: build
>    Affects Versions: 0.19.1
>         Environment: SunOS dcache09 5.10 Generic_127128-11 i86pc i386 i86pc
> SunFire X4500 Thumper
>            Reporter: Carl Lundstedt
>
> I checked out branch-0.19 from svn and attempted a build.
>  ant -Dcompile.native=true -Dnonspace.os=SunOS -Dmake.cmd=gmake clean tar
>      [exec] gmake[2]: Entering directory `/opt/hadoop/hadoop-0.19.1/branch-0.19/build/native/SunOS-x86-32/src/org/apache/hadoop/io/compress/lzo'
>      [exec] if /bin/sh ../../../../../../../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H
-I. -I/opt/hadoop/hadoop-0.19.1/branch-0.19/src/native/src/org/apache/hadoop/io/compress/lzo
-I../../../../../../..  -I/opt/SDK/jdk//include -I/opt/SDK/jdk//include/solaris -I/opt/hadoop/hadoop-0.19.1/branch-0.19/src/native/src
 -g -Wall -fPIC -O2 -m32 -g -O2 -MT LzoCompressor.lo -MD -MP -MF ".deps/LzoCompressor.Tpo"
-c -o LzoCompressor.lo /opt/hadoop/hadoop-0.19.1/branch-0.19/src/native/src/org/apache/hadoop/io/compress/lzo/LzoCompressor.c;
\
>      [exec]     then mv -f ".deps/LzoCompressor.Tpo" ".deps/LzoCompressor.Plo"; else
rm -f ".deps/LzoCompressor.Tpo"; exit 1; fi
>      [exec] mkdir .libs
>      [exec]  gcc -DHAVE_CONFIG_H -I. -I/opt/hadoop/hadoop-0.19.1/branch-0.19/src/native/src/org/apache/hadoop/io/compress/lzo
-I../../../../../../.. -I/opt/SDK/jdk//include -I/opt/SDK/jdk//include/solarop/hadoop-0.19.1/branch-0.19/src/native/src
-g -Wall -fPIC -O2 -m32 -g -O2 -MT LzoCompressor.lo -MD -MP -MF .deps/LzoCompressor.Tpo -c
/opt/hadoop/hadoop-0.19.1/branch-0.19/src/native/src/org/apache/hads/lzo/LzoCompressor.c 
-fPIC -DPIC -o .libs/LzoCompressor.o
>      [exec] /opt/hadoop/hadoop-0.19.1/branch-0.19/src/native/src/org/apache/hadoop/io/compress/lzo/LzoCompressor.c:
In function `Java_org_apache_hadoop_io_compress_lzo_LzoCompressor_initIDs':
>      [exec] /opt/hadoop/hadoop-0.19.1/branch-0.19/src/native/src/org/apache/hadoop/io/compress/lzo/LzoCompressor.c:137:
error: syntax error before ',' token
>      [exec] gmake[2]: *** [LzoCompressor.lo] Error 1
>      [exec] gmake[2]: Leaving directory `/opt/hadoop/hadoop-0.19.1/branch-0.19/build/native/SunOS-x86-32/src/org/apache/hadoop/io/compress/lzo'
>      [exec] gmake[1]: *** [all-recursive] Error 1
>      [exec] gmake[1]: Leaving directory `/opt/hadoop/hadoop-0.19.1/branch-0.19/build/native/SunOS-x86-32'
>      [exec] gmake: *** [all] Error 2
> Not sure what the cause or fix may be.  

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message