hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Konstantin Boudnik (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-6204) Implementing aspects development and fault injeciton framework for Hadoop
Date Thu, 27 Aug 2009 20:25:59 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-6204?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12748553#action_12748553

Konstantin Boudnik commented on HADOOP-6204:

In order to avoid some massive ANT code duplication, I have sketched a solution for this as
  - all FI logic is represented by a separate aop.xml file placed in build.aux folder
  - that aop.xml file is imported into build.xml
  - to make FI framework project independent I've renamed FI related targets to {{run-test-primary-fault-inject}}.
{{run-test-secondary-fault-inject}}, {{jar-fault-inject}}, and {{jar-test-fault-inject}}
  - project specific build.properties should contains actual target to be executed by aforementioned
generic names.

Now, build.aux can be pulled from Common through svn:externals and then everything will be
working in a very similar way. The above solution has 2 issues in my opinion:
  - an indirection level is being added. One way to avoid the abstraction is to define a number
of macros in the aop.xml file and parametrize them from build.xml. It might be better approach.
  - svn:externals aren't universally acceptable. E.g. if one wants to pull SVN repository
into a git one, then externals are have to be processed as a special case.

I'd appreciate if anyone has any comment or preferences on this.

> Implementing aspects development and fault injeciton framework for Hadoop
> -------------------------------------------------------------------------
>                 Key: HADOOP-6204
>                 URL: https://issues.apache.org/jira/browse/HADOOP-6204
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: build, test
>            Reporter: Konstantin Boudnik
>            Assignee: Konstantin Boudnik
> Fault injection framework implementation in HDFS (HDFS-435) turns out to be a very useful
feature both for error handling testing and for various simulations.
> There's certain demand for this framework, thus it need to be pulled up from HDFS and
brought into Common, so other sub-projects will be able to share it if needed.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message