hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stephen mulcahy (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HADOOP-3744) Eclipse Plugin does not work with Eclipse Ganymede (3.4)
Date Thu, 20 Aug 2009 15:09:14 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-3744?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12745454#action_12745454
] 

stephen mulcahy commented on HADOOP-3744:
-----------------------------------------

I ran into the same problem with Eclipse 3.4 on Debian Linux 5.0 - I could browse DFS with
the eclipse plugin from hadoop 0.19.2 but I couldn't run a Hadoop Job.

I checked out http://svn.apache.org/repos/asf/hadoop/common/tags/release-0.19.2/ and rebuilt
the plugin against my local eclipse as follows,

ant -Declipse.home=/usr/local/eclipse clean package

and copied the resulting plugin .jar file to /usr/local/eclipse/plugins.

For some reason the MapReduce perspective was no longer available and I couldn't see any error
from Eclipse. I figure maybe moving from one version of the plugin to another might have corrupted
something in Eclipse?

Anyways - since I was at it, I tried installing the latest Eclipse (3.5, Galileo) and rebuilt
the plugin against this version. I then installed it as above and start Eclipse.

This time the plugin works perfectly - I can both browse DFS and run a job against Hadoop.
So, in conclusion, the patch works against Eclipse 3.5 (on Linux at least) also.

+1 on including this in the release.


> Eclipse Plugin does not work with Eclipse Ganymede (3.4)
> --------------------------------------------------------
>
>                 Key: HADOOP-3744
>                 URL: https://issues.apache.org/jira/browse/HADOOP-3744
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: contrib/eclipse-plugin
>    Affects Versions: 0.16.4, 0.17.0, 0.19.2
>         Environment: Windows XP with Eclipse "Ganymede" 3.4
>            Reporter: Aaron Kimball
>            Assignee: Christophe Taton
>         Attachments: HADOOP-3744.patch, HadoopApplicationLaunchShortcut.diff
>
>
> The newest version of Eclipse seems incompatible with the plugin. The plugin as released
in 0.16.4 will allow you to add/remove MapReduce servers, and will allow you to browse/manipulate
the DFS in the DFS Browser, but will not allow you to run programs. Clicking "Run As * Run
On Hadoop" will simply not cause the run-on-hadoop server selection window to appear. No error
message is given.
> Dropping the 0.17.1 copy of the plugin JAR into the eclipse/plugins/ directory does not
fix the issue; it is in fact worse: Eclipse does not seem to regard the 0.17 plugin as real.
No "MapReduce Perspective" is made available in the perspectives selection window.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message