hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Li Lu <...@hortonworks.com>
Subject Re: [DISCUSS] Set minimum version of Hadoop 3 to JDK8 (HADOOP-11858)
Date Thu, 12 May 2016 18:53:26 GMT
I’d like to bring YARN-4977 into attention for using Java 8. HADOOP-13083 does the maven
change and in yarn-api there are ~5000 javadoc warnings. 

Li Lu

> On May 10, 2016, at 08:32, Akira AJISAKA <ajisakaa@oss.nttdata.co.jp> wrote:
> 
> Hi developers,
> 
> Before cutting 3.0.0-alpha RC, I'd like to drop JDK7 support in trunk.
> Given this is a critical change, I'm thinking we should get the consensus first.
> 
> One concern I think is, when the minimum version is set to JDK8, we need to configure
Jenkins to disable multi JDK test only in trunk.
> 
> Any thoughts?
> 
> Thanks,
> Akira
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: yarn-dev-unsubscribe@hadoop.apache.org
> For additional commands, e-mail: yarn-dev-help@hadoop.apache.org
> 
> 

Mime
View raw message