hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Colin McCabe <cmcc...@apache.org>
Subject Re: [DISCUSS] upgrade tomcat from 6.0.44 to 6.0.45 and use non apache.org mirror
Date Mon, 23 May 2016 18:35:58 GMT
I think the Tomcat situation is concerning in a lot of ways.

1. We are downloading without authentication, using http rather than
https.
2. We are downloading an obsolete release.
3. Our build process is violating the apache.archive.org guidelines by
downloading from the site directly, rather than from a mirror.
4. Clean builds take longer than necessary because this tar file needs
to be downloaded.

I'm not too familiar with how Tomcat works... does anyone have any ideas
for fixing this?

best,
Colin


On Tue, May 17, 2016, at 14:08, Wangda Tan wrote:
> Hi common-devs,
> 
> When I tried to build Hadoop trunk today, Maven build failed because kms
> failed to download:
> http://archive.apache.org/dist/tomcat/tomcat-6/v6.0.44/bin/apache-tomcat-6.0.44.tar.gz
> .
> 
> When I open the link from browser, it shows bandwidth limit exceeded:
> 
> ===
> Bandwidth limit exceeded
> 
> The daily allowance of 5GB for this IP has been exceeded, and downloads
> disabled until midnight, UTC (circa 21 hours from now).
> If you have any questions about this, feel free to reach out to us at
> infrastructure@apache.org.
> ===
> 
> Then I investigated a little more, there're two issues from what I can
> see
> 1) If you look at http://archive.apache.org/dist/, it clearly says:
> *> Please do not download from apache.org <http://apache.org>!*
> 
> 2) And also, http://archive.apache.org/dist/ says:
> > Older *non-recommended* releases can be found on our archive site
> <http://archive.apache.org/dist/>.
> 
> We're using tomcat with version=6.0.44, on other Apache mirror site, only
> 6.0.45 tomcat is downloadable. Which essentially means 6.0.44 is a
> non-recommended release.
> 
> I would like to propose to make following changes:
> 1) Update tomcat download site from apache.org to another mirror.
> 2) Upgrade tomcat from 6.0.44 to 6.0.45.
> 
> But would like to hear your thoughts before filing JIRA.
> 
> Thanks,
> Wangda

---------------------------------------------------------------------
To unsubscribe, e-mail: common-dev-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-dev-help@hadoop.apache.org


Mime
View raw message