hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alan Burlison <Alan.Burli...@oracle.com>
Subject Re: Protocol Buffers version
Date Thu, 18 Jun 2015 18:52:53 GMT
On 16/06/2015 10:54, Steve Loughran wrote:

>>>> One reason at least: PB 2.5.0 has no support for Solaris SPARC. 2.6.1 does.
>
> to be ruthless, that's not enough reason to upgrade branch-2, due to the transitive pain
it makes all the way down.

I completely get your point, however we are faced with two pretty 
equally unpalatable options, either fork PB 2.5.0 and add support for 
Solaris SPARC or switch to 2.6.1.

Although as I've found out, even though 2.6.1 claims to support Solaris 
SPARC it doesn't, and needs a patch (albeit a small one) to get it to 
work :-/ From what I can gather, cross-platform support in PB breaks 
fairly regularly,

-- 
Alan Burlison
--

Mime
View raw message