hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alan Burlison <Alan.Burli...@oracle.com>
Subject HADOOP-9279 still not fixed, needs reopening
Date Wed, 13 May 2015 11:14:13 GMT
https://issues.apache.org/jira/browse/HADOOP-9279

Document the need to build hadoop-maven-plugins for eclipse and separate 
project builds

Although the BUILDING.txt mentions the need to to build 
hadoop-maven-plugins for Eclipse, it's actually needed for *all* builds, 
even from the top level, otherwise a top-level build will fail with:

[ERROR] Failed to parse plugin descriptor for 
org.apache.hadoop:hadoop-maven-plugins:3.0.0-SNAPSHOT 
(/pool1/home/alanbur/bleaklow/bigdata/hadoop/hadoop-maven-plugins/target/classes): 
No plugin descriptor found at META-INF/maven/plugin.xml -> [Help 1]

Manually building hadoop-maven-plugins fixes the problem, but if I'm 
reading HADOOP-9279 right it shouldn't be required. What's the correct 
course of action here, reopen HADOOP-9279 or log a new bug? If it's the 
former I can't see any way of reopening it in JIRA, presumably because 
I'm not blessed enough to do so.

Thanks,

-- 
Alan Burlison
--

Mime
View raw message