hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zoran Dimitrijevic (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HADOOP-11876) Refactor code to make it more readable, minor maybePrintStats bug
Date Fri, 24 Apr 2015 17:19:38 GMT
Zoran Dimitrijevic created HADOOP-11876:
-------------------------------------------

             Summary: Refactor code to make it more readable, minor maybePrintStats bug
                 Key: HADOOP-11876
                 URL: https://issues.apache.org/jira/browse/HADOOP-11876
             Project: Hadoop Common
          Issue Type: Bug
          Components: tools/distcp
    Affects Versions: 3.0.0
            Reporter: Zoran Dimitrijevic
            Assignee: Zoran Dimitrijevic
            Priority: Trivial


This is related to HADOOP-11827 patch from few days ago. I've noticed a minor bug in maybePrintStats
logic which is called only when new directory is processed, and prints every 100K objects
(effectively, there is a very low probability it'll ever print stats). The reason for this
bug is that I was previously printing stats for every new directory, and later decided it's
nicer to print stats for large number of new "objects" (files or directories) instead. 

This is a minor issue - and since I'm refactoring this I've also changed the minor retry logic
to make code nicer and more readable.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message