hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yongjun Zhang <yzh...@cloudera.com>
Subject Re: Erratic Jenkins behavior
Date Thu, 05 Feb 2015 18:42:01 GMT
Thanks Kihwal for bringing this up.

Seems related to:

https://issues.apache.org/jira/browse/HADOOP-11084

Hi Andrew/Arpit/Colin/Steve, you guys worked on this jira before, any
insight about the issue Kihwal described?

Thanks.

--Yongjun


On Thu, Feb 5, 2015 at 9:49 AM, Kihwal Lee <kihwal@yahoo-inc.com.invalid>
wrote:

> I am sure many of us have seen strange jenkins behavior out of the
> precommit builds.
>
> - build artifacts missing
> - serving build artifact belonging to another build. This also causes
> wrong precommit results to be posted on the bug.
> - etc.
>
> The latest one I saw is disappearance of the unit test stdout/stderr file
> during a build. After a successful run of unit tests, the file vanished, so
> the script could not cat it. It looked like another build process had
> deleted it, while this build was in progress.
>
> It might have something to do with the fact that the patch-dir is set like
> following:
>
> PATCHPROCESS=/home/jenkins/jenkins-slave/workspace/PreCommit-HDFS-Build/../patchprocessI
> don't have access to the jenkins build configs or the build machines, so I
> can't debug it further, but I think we need to take care of it sooner than
> later.  Can any one help?
>
> Kihwal
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message