hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anand Murali (JIRA)" <j...@apache.org>
Subject [jira] [Reopened] (HADOOP-11315) Cannot compile Hadoop Code
Date Fri, 21 Nov 2014 07:25:34 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-11315?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Anand Murali reopened HADOOP-11315:
-----------------------------------

Made following changes to .bashrc to explicitly point to the hadoop CLASSES

export JAVA_INSTALL=/home/anand_vihar/jdk170/bin
export JAVA_HOME=/home/anand_vihar/jdk170/
export HADOOP_INSTALL=/home/anand_vihar/hadoop
export HADOOP_HOME=/home/anand_vihar/hadoop/
export PATH=:$PATH:$HADOOP_HOME/bin:$JAVA_HOME:$JAVA_INSTALL:$HADOOP_INSTALL/bin:$HADOOP_INSTALL/sbin:$HADOOP_INSTALL/share/hadoop/common:$HADOOP_INSTALL/share/hadoop/mapreduce:$HADOOP_INSTALL/share/hadoop/yarn

Still get following errors

MaxTemperatureMapper.java:1: error: package org.apache.hadoop.io does not exist          
                  
import org.apache.hadoop.io.IntWritable;                                                 
                  
                           ^                                                             
                  
MaxTemperatureMapper.java:2: error: package org.apache.hadoop.io does not exist          
                  
import org.apache.hadoop.io.LongWritable;                                                
                  
                           ^                                                             
                  
MaxTemperatureMapper.java:3: error: package org.apache.hadoop.io does not exist          
                  
import org.apache.hadoop.io.Text;                                                        
                  
                           ^                                                             
                  
MaxTemperatureMapper.java:4: error: package org.apache.hadoop.mapreduce does not exist   
                  
import org.apache.hadoop.mapreduce.Mapper;                                              

Can somebody help me resolve this rather then closing it. I have sent this to user@hadoop
and that E-mail does not exist. This is a show stopper for me, and nobody here or anywhere
has responded. Shall be very thankful if somebody can help. Thanks

Regards,

Anand Murali

> Cannot compile Hadoop Code
> --------------------------
>
>                 Key: HADOOP-11315
>                 URL: https://issues.apache.org/jira/browse/HADOOP-11315
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: bin
>    Affects Versions: 2.2.0
>         Environment: Suse desktop 11.0 on i7 chipset, running jdk1.7.0_71 and Hadoop2.2.0
>            Reporter: Anand Murali
>            Priority: Critical
>
> Following customizations made to hadoop-env.sh to get Hadoop started
> export JAVA_HOME=/home/anand_vihar/jdk1.7.0_71/
> export HADOOP_INSTALL=/home/anand_vihar/hadoop-2.2.0/*
> export HADOOP_HOME=:$HADOOP_INSTALL
> export PATH=:$PATH:$HADOOP_INSTALL/bin:$HADOOP_INSTALL/sbin:$HADOOP_HOME/share:$JAVA_HOME:$JAVA_HOME/bin
> Next at linux prompt typed
> $javac MaxTemperatureMapper.java
> compile fails with class not found errors. Tried giving direct classpath to share as
above and still errors out. However, on typing "hadoop version". it runs and picks up the
required jars in share.. Have raised this issue a coupld of times in the last 1 week and it
is closed as not replicable. But issue persists. Checked on user forums, but no help. Request
assistance



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message