hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brahma Reddy Battula <brahmareddy.batt...@huawei.com>
Subject RE: unable to use hdfs haadmin -ns <nameserviceId> on HDP2.1 , HDFS2.4.0.2.1
Date Mon, 03 Nov 2014 07:21:58 GMT
Hi Mittra


As far as I knew, "hdfs haadmin -ns" is not availble..(please someone can correct, If I am
wrong..)


Please check following help command for haadmin..

[root@linux bin]# ./hdfs haadmin
No GC_PROFILE is given. Defaults to medium.
Usage: DFSHAAdmin [-ns <nameserviceId>]
    [-transitionToActive <serviceId> [--forceactive]]
    [-transitionToStandby <serviceId>]
    [-failover [--forcefence] [--forceactive] <serviceId> <serviceId>]
    [-getServiceState <serviceId>]
    [-checkHealth <serviceId>]
    [-help <command>]


Example:

if your service id's are like nn1,nn2

then you can try like,, hdfs haadmin -getServiceState nn1.


Thanks & Regards
Brahma Reddy Battula
________________________________________
From: Devopam Mittra [devopam@gmail.com]
Sent: Monday, November 03, 2014 10:33 AM
To: common-dev@hadoop.apache.org
Subject: unable to use hdfs haadmin -ns <nameserviceId> on HDP2.1 , HDFS2.4.0.2.1

hi All,
I wanted to systematically probe and list all my namenode(s) via CLI.
An easier way was to maintain a masters conf file , but I want to
dynamically find the same leveraging the system metadata.

In process of trying to find the same , I tried to use
hdfs haadmin -ns ... but to my dismay the command always returns "Missing
Command" on the console as if I am doing something syntactically wrong.

I know my nameserviceId and I tried both capital letters and all small
(just to be sure to not commit a silly mistake).

Can you please help me in trying to figure out what I am doing wrong here.


--
Devopam Mittra
Life and Relations are not binary

Mime
View raw message