hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Niels Basjes <Ni...@basjes.nl>
Subject Re: Jenkins problem or patch problem?
Date Sun, 27 Jul 2014 20:27:52 GMT
I created a patch file with SVN and it works now.
I dare to ask: Are there any git created patch files that work?


On Sun, Jul 27, 2014 at 9:44 PM, Niels Basjes <Niels@basjes.nl> wrote:

> I'll look for a workaround regarding the binary file. Thanks.
>
>
> On Sun, Jul 27, 2014 at 9:07 PM, Ted Yu <yuzhihong@gmail.com> wrote:
>
>> Similar problem has been observed for HBase patches.
>>
>> Have you tried attaching level 1 patch ?
>> For the binary file, to my knowledge, 'git apply' is able to handle it but
>> hadoop is currently using svn.
>>
>> Cheers
>>
>>
>> On Sun, Jul 27, 2014 at 11:01 AM, Niels Basjes <Niels@basjes.nl> wrote:
>>
>> > Hi,
>> >
>> > I just submitted a patch and Jenkins said it failed to apply the patch.
>> > But when I look at the console output
>> >
>> > https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/4771//console
>> >
>> > it says:
>> >
>> > At revision 1613826.
>> > MAPREDUCE-2094 patch is being downloaded at Sun Jul 27 18:50:44 UTC
>> > 2014 fromhttp://
>> >
>> issues.apache.org/jira/secure/attachment/12658034/MAPREDUCE-2094-20140727.patch*cp
>> > :
>> > cannot stat '/home/jenkins/buildSupport/lib/*': No such file or
>> > directory
>> > *The patch does not appear to apply with p0 to p2
>> > PATCH APPLICATION FAILED
>> >
>> >
>> > Now I do have a binary file (for the unit test) in this patch, perhaps I
>> > did something wrong? Or is this problem caused by the error I
>> highlighted?
>> >
>> > What can I do to fix this?
>> >
>> > --
>> > Best regards / Met vriendelijke groeten,
>> >
>> > Niels Basjes
>> >
>>
>
>
>
> --
> Best regards / Met vriendelijke groeten,
>
> Niels Basjes
>



-- 
Best regards / Met vriendelijke groeten,

Niels Basjes

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message