hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jing Zhao (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HADOOP-10441) Namenode metric "rpc.RetryCache/NameNodeRetryCache.CacheHit" can't be correctly processed by Ganglia
Date Wed, 26 Mar 2014 17:49:22 GMT
Jing Zhao created HADOOP-10441:
----------------------------------

             Summary: Namenode metric "rpc.RetryCache/NameNodeRetryCache.CacheHit" can't be
correctly processed by Ganglia
                 Key: HADOOP-10441
                 URL: https://issues.apache.org/jira/browse/HADOOP-10441
             Project: Hadoop Common
          Issue Type: Bug
    Affects Versions: 2.4.0
            Reporter: Jing Zhao
            Assignee: Jing Zhao
            Priority: Minor


The issue is reported by [~dsen]:

Recently added Namenode metric "rpc.RetryCache/NameNodeRetryCache.CacheHit" can't be correctly
processed by Ganglia because its name contains "/"

Proposal: Namenode metric "rpc.RetryCache/NameNodeRetryCache.CacheHit" should be renamed to
"rpc.RetryCache.NameNodeRetryCache.CacheHit"
Here - org.apache.hadoop.ipc.metrics.RetryCacheMetrics#RetryCacheMetrics
{code}
  RetryCacheMetrics(RetryCache retryCache) {
    name = "RetryCache/"+ retryCache.getCacheName();
    registry = new MetricsRegistry(name);
    if (LOG.isDebugEnabled()) {
      LOG.debug("Initialized "+ registry);
    }
  }
{code}



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message