hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tsuyoshi OZAWA (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (HADOOP-9822) create constant MAX_CAPACITY in RetryCache rather than hard-coding 16 in RetryCache constructor
Date Sat, 15 Mar 2014 11:15:43 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-9822?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Tsuyoshi OZAWA resolved HADOOP-9822.
------------------------------------

    Resolution: Invalid

> create constant MAX_CAPACITY in RetryCache rather than hard-coding 16 in RetryCache constructor
> -----------------------------------------------------------------------------------------------
>
>                 Key: HADOOP-9822
>                 URL: https://issues.apache.org/jira/browse/HADOOP-9822
>             Project: Hadoop Common
>          Issue Type: Bug
>    Affects Versions: 3.0.0, 2.1.1-beta, 2.3.0
>            Reporter: Tsuyoshi OZAWA
>            Assignee: Tsuyoshi OZAWA
>            Priority: Minor
>         Attachments: HADOOP-9822.1.patch, HADOOP-9822.2.patch
>
>
> The magic number "16" is also used in ClientId.BYTE_LENGTH, so hard-coding magic number
"16" is a bit confusing.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message