hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anand Murali (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HADOOP-10060) Unable to run JDK_1.7.1_40 commands in Cygwin2.829 (32 bit
Date Sun, 20 Oct 2013 09:16:42 GMT
Anand Murali created HADOOP-10060:
-------------------------------------

             Summary: Unable to run JDK_1.7.1_40 commands in Cygwin2.829 (32 bit
                 Key: HADOOP-10060
                 URL: https://issues.apache.org/jira/browse/HADOOP-10060
             Project: Hadoop Common
          Issue Type: Task
          Components: bin
    Affects Versions: 1.2.1
         Environment: Background
 
I have installed Cygwin to self learn Hadoop 1.2.1 with the above JDK in Cygwin environment
on Windows XP- SP2 laptop

            Reporter: Anand Murali
            Priority: Blocker
             Fix For: 1.2.1


Actions Performed 
 
1. As advised by Hadoop exported JAVA_HOME=/cygwin/jdk1.2.7_40/bin in hadoop-env.sh and tried
to run java commands with error 
 	jar  /cygwin/hadoop-1.2.1/hadoop-examples-1.2.1.jar
              -bash: jar: command not found
 2. However when echoed  I get right pointed path
 	echo $JAVA_HOME
               /cygwin/jdk1.7.0_40/bin
 3. Tried including export path in .bash_profile, and .profile, with same error.
 
Unable to move forward with out JDK calls. Anticipate the same with Hadoop related commands.




--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message