hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Harsh J <ha...@cloudera.com>
Subject Re: protobuf upgrade on Jenkins slaves causing build failures?
Date Tue, 13 Aug 2013 03:04:27 GMT
Hey Chris,

Yep the protobuf version on the machine was upped. We have a parallel
ongoing discussion on the same lists under the title "Upgrade to
protobuf 2.5.0 for the 2.1.0 release" which you can follow for the
updates being done.

On Mon, Aug 12, 2013 at 11:00 PM, Chris Nauroth
<cnauroth@hortonworks.com> wrote:
> I'm curious if protobuf may have been upgraded to 2.5.0 on the Jenkins
> slaves, ahead of committing the Hadoop code's dependency upgrade to 2.5.0.
>  We've started to see build failures due to cannot find symbol
> com.google.protobuf.Parser.  This is the earliest example I could find,
> which happened 8/11 10:31 AM:
>
> https://builds.apache.org/job/Hadoop-Yarn-trunk/298/
>
> The Parser class does not exist in 2.4.1, but it does exist in 2.5.0, which
> leads me to believe that the Jenkins machines were upgraded to start using
> a 2.5.0 protoc binary.
>
> Chris Nauroth
> Hortonworks
> http://hortonworks.com/



-- 
Harsh J

Mime
View raw message