hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Scott Bressler (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HADOOP-9568) Improve JobClient messaging by adding job name to the output
Date Fri, 17 May 2013 02:21:16 GMT
Scott Bressler created HADOOP-9568:
--------------------------------------

             Summary: Improve JobClient messaging by adding job name to the output
                 Key: HADOOP-9568
                 URL: https://issues.apache.org/jira/browse/HADOOP-9568
             Project: Hadoop Common
          Issue Type: Improvement
          Components: conf
         Environment: Hadoop 0.20.203, Linux RHEL5 64-bit
            Reporter: Scott Bressler


Currently, the JobClient outputs to the terminal something like the following when starting
a job:
13/05/17 01:56:52 INFO mapred.JobClient: Running job: job_201305161755_0020

I would like to change to add the job name, making it something like:
13/05/17 01:56:52 INFO mapred.JobClient: Running job: [JOB-NAME] (job_201305161755_0020)

Of course the job ID could be kept as the primary naming scheme if that's preferred, but I
think showcasing the name is best.

Will add a patch by the weekend if no one else does first.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message