hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Loughran (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (HADOOP-8630) rename isSingleSwitch() methods in new topo base class to isFlatTopology()
Date Mon, 15 Apr 2013 18:44:16 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-8630?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Steve Loughran resolved HADOOP-8630.

    Resolution: Won't Fix
      Assignee: Tsuyoshi OZAWA

Marking as wontfix but crediting Tsuyoshi Ozawa for his contribution
> rename isSingleSwitch() methods in new topo base class to isFlatTopology()
> --------------------------------------------------------------------------
>                 Key: HADOOP-8630
>                 URL: https://issues.apache.org/jira/browse/HADOOP-8630
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: util
>    Affects Versions: 2.0.0-alpha, 3.0.0
>            Reporter: Steve Loughran
>            Assignee: Tsuyoshi OZAWA
>            Priority: Trivial
>         Attachments: HADOOP-8630.2.patch, HADOOP-8630.patch
>   Original Estimate: 0.5h
>  Remaining Estimate: 0.5h
> The new topology logic that is not yet turned on in HDFS uses the method {{isSingleSwitch()}}
for implementations to declare whether or not they are single switch. 
> The use of "switch" is an implementation issue; the big VM-based patch shows that really
it's about "flat" vs "hierarchical", with Hadoop assuming that subtrees in the hierarchy have
better bandwidth (good) but correlated failures (bad). 
> Renaming the method now -before it's fixed and used- is time time to do it. 

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message