hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tsz Wo (Nicholas), SZE (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HADOOP-8700) Move the checksum type constants to an enum
Date Wed, 15 Aug 2012 10:10:38 GMT
Tsz Wo (Nicholas), SZE created HADOOP-8700:
----------------------------------------------

             Summary: Move the checksum type constants to an enum
                 Key: HADOOP-8700
                 URL: https://issues.apache.org/jira/browse/HADOOP-8700
             Project: Hadoop Common
          Issue Type: Improvement
          Components: util
            Reporter: Tsz Wo (Nicholas), SZE
            Assignee: Tsz Wo (Nicholas), SZE
            Priority: Minor


In DataChecksum, there are constants for crc types, crc names and crc sizes.  We should move
them to an enum for better coding style.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message