hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pavan Kulkarni <pavan.babu...@gmail.com>
Subject Re: Problem setting up 1st generation Hadoop-0.20 (ANT build) in Eclipse
Date Wed, 11 Jul 2012 20:24:18 GMT
I resolved the issue of "*Exception in thread "main"
java.lang.InternalError: Can't connect to X11 window server using ':0' as
the value of the DISPLAY variable."*.
The problem was if the "ant tar" is being issued from root whereas the
owner of the X Display Socket belongs to different user then, the error
pops up.
So to avoid this
execute "*xhost +local:all*" in the terminal of the user who owns the X
Display socket and then try issuing ant from root. It works fine. This does
have some security concerns but this is the easiest workaround

On Tue, Jul 10, 2012 at 5:50 PM, Pavan Kulkarni <pavan.baburao@gmail.com>wrote:

> I tried *"ant tar"* but it requested a forrest home directory ,so I ran
> *"ant -Dforrest.home=/path/apache-forrest-0.8 compile-core tar"*
> but this gets stuck at an Exception
> "Exception in thread "main" java.lang.InternalError: Can't connect to X11
> window server using ':0' as the value of the DISPLAY variable."
> No idea what this exception means. How come there isn't a good
> documentation or a BUILDING.txt file for MR1 releases ? Any help regarding
> this is appreciated.Thanks
>
>
> On Tue, Jul 10, 2012 at 4:29 PM, Harsh J <harsh@cloudera.com> wrote:
>
>> Hey Pavan,
>>
>> Try an "ant tar". For more ant targets, read the build.xml at the root
>> of your checkout.
>>
>> On Wed, Jul 11, 2012 at 1:15 AM, Pavan Kulkarni <pavan.baburao@gmail.com>
>> wrote:
>> > Thanks a lot Harsh.I could set it up without any errors.
>> > It would be great if you could provide me any pointers on how to build a
>> > binary distribution tar file.
>> > The information on wiki and in BUILDING.txt only has Maven
>> > instructions.Thanks
>> >
>> > On Tue, Jul 10, 2012 at 2:39 PM, Harsh J <harsh@cloudera.com> wrote:
>> >
>> >> Hey Pavan,
>> >>
>> >> The 0.20.x version series was renamed recently to 1.x. Hence, you need
>> >> to use the branch-1 code path if you want the latest stable branch
>> >> (MR1, etc.) code.
>> >>
>> >> Do these once you have ant 1.8 and a Sun/Oracle JDK 1.6 installed, and
>> >> you should have it:
>> >>
>> >> $ git clone http://github.com/apache/hadoop-common.git hadoop-1
>> >> $ cd hadoop-1; git checkout branch-1
>> >> $ ant eclipse
>> >>
>> >> (Now export this directory into Eclipse as a Java project)
>> >>
>> >> HTH.
>> >>
>> >> On Wed, Jul 11, 2012 at 12:00 AM, Pavan Kulkarni
>> >> <pavan.baburao@gmail.com> wrote:
>> >> > Hi all,
>> >> >
>> >> >   I am trying to setup hadoop 1st generation 0.20 in Eclipse which
>> still
>> >> > uses Ant as its build tool.
>> >> > The build was successful , but when I want to set it up in the
>> Eclipse
>> >> IDE
>> >> > i.e
>> >> > *File-> new Project-> Project from existing ANT build file ->
Select
>> >> > build.xml ->Finish*
>> >> > I get this following error :
>> >> > *Problem setting the classpath of the project from the javac
>> classpath:
>> >> > Reference ivy-common.classpath not found.*
>> >> >
>> >> >  I have tried finding solutions online but couldn't get a concrete
>> one.
>> >> Are
>> >> > there any sources or workarounds on setting 1st generation
>> >> > Hadoop in Eclipse.?
>> >> >
>> >> > Also my second question was how to build a binary tar file for
>> >> hadoop-0.20
>> >> > which still uses ANT. The wiki pages only have information for maven.
>> >> > Any help is highly appreciated.Thanks
>> >> > --
>> >> >
>> >> > --With Regards
>> >> > Pavan Kulkarni
>> >>
>> >>
>> >>
>> >> --
>> >> Harsh J
>> >>
>> >
>> >
>> >
>> > --
>> >
>> > --With Regards
>> > Pavan Kulkarni
>>
>>
>>
>> --
>> Harsh J
>>
>
>
>
> --
>
> --With Regards
> Pavan Kulkarni
>
>


-- 

--With Regards
Pavan Kulkarni

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message