hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Harsh J <ha...@cloudera.com>
Subject Re: Problem setting up 1st generation Hadoop-0.20 (ANT build) in Eclipse
Date Tue, 10 Jul 2012 18:39:49 GMT
Hey Pavan,

The 0.20.x version series was renamed recently to 1.x. Hence, you need
to use the branch-1 code path if you want the latest stable branch
(MR1, etc.) code.

Do these once you have ant 1.8 and a Sun/Oracle JDK 1.6 installed, and
you should have it:

$ git clone http://github.com/apache/hadoop-common.git hadoop-1
$ cd hadoop-1; git checkout branch-1
$ ant eclipse

(Now export this directory into Eclipse as a Java project)

HTH.

On Wed, Jul 11, 2012 at 12:00 AM, Pavan Kulkarni
<pavan.baburao@gmail.com> wrote:
> Hi all,
>
>   I am trying to setup hadoop 1st generation 0.20 in Eclipse which still
> uses Ant as its build tool.
> The build was successful , but when I want to set it up in the Eclipse IDE
> i.e
> *File-> new Project-> Project from existing ANT build file -> Select
> build.xml ->Finish*
> I get this following error :
> *Problem setting the classpath of the project from the javac classpath:
> Reference ivy-common.classpath not found.*
>
>  I have tried finding solutions online but couldn't get a concrete one. Are
> there any sources or workarounds on setting 1st generation
> Hadoop in Eclipse.?
>
> Also my second question was how to build a binary tar file for hadoop-0.20
> which still uses ANT. The wiki pages only have information for maven.
> Any help is highly appreciated.Thanks
> --
>
> --With Regards
> Pavan Kulkarni



-- 
Harsh J

Mime
View raw message