hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Luke Lu (Resolved) (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (HADOOP-7211) Security uses proprietary Sun APIs
Date Fri, 06 Apr 2012 05:31:34 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-7211?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Luke Lu resolved HADOOP-7211.
-----------------------------

          Resolution: Duplicate
    Target Version/s: 1.0.3, 2.0.0

This jira is incorporated by the patches in HADOOP-6941 and HADOOP-7211
                
> Security uses proprietary Sun APIs
> ----------------------------------
>
>                 Key: HADOOP-7211
>                 URL: https://issues.apache.org/jira/browse/HADOOP-7211
>             Project: Hadoop Common
>          Issue Type: Improvement
>          Components: security
>            Reporter: Eli Collins
>            Assignee: Luke Lu
>
> The security code uses the KrbException, Credentials, and PrincipalName classes from
sun.security.krb5 and Krb5Util from sun.security.jgss.krb5. These may disappear in future
Java releases. Also Hadoop does not compile using jdks that do not support them, for example
with the following IBM JDK.
> {noformat}
> $ /home/eli/toolchain/java-x86_64-60/bin/java -version
> java version "1.6.0"
> Java(TM) SE Runtime Environment (build pxa6460sr9fp1-20110208_03(SR9 FP1))
> IBM J9 VM (build 2.4, JRE 1.6.0 IBM J9 2.4 Linux amd64-64 jvmxa6460sr9-20110203_74623
(JIT enabled, AOT enabled)
> J9VM - 20110203_074623
> JIT  - r9_20101028_17488ifx3
> GC   - 20101027_AA)
> JCL  - 20110203_01
> {noformat}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message