hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kumar Ravi <kum...@us.ibm.com>
Subject Failing 2 junit tests in hadoop-1.0.1
Date Mon, 05 Mar 2012 21:29:58 GMT


 I am seeing failures running these two tests for hadoop-1.0.1 from
svn.apache.org and using Sun/oracle Java ver. 1.6.0_31.

1. Test org.apache.hadoop.mapred.TestTTResourceReporting

2. Test org.apache.hadoop.streaming.TestUlimit

On the TTResourceReporting test, the error was an IOException --

Testcase: testConfiguredResourceValues took 85.934 sec
        Caused an ERROR
Job failed!
java.io.IOException: Job failed!
        at org.apache.hadoop.mapred.JobClient.runJob(JobClient.java:1265)
        at org.apache.hadoop.examples.SleepJob.run(SleepJob.java:174)
        at org.apache.hadoop.examples.SleepJob.run(SleepJob.java:237)
        at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:65)
        at org.apache.hadoop.mapred.TestTTResourceReporting.runSleepJob

On Ulimit test. I am seeing the same symptoms reported and resolved by

This is the error I am seeing:

Testcase: testCommandLine took 86.104 sec
output is wrong expected:<[786432]> but was:<[]>
junit.framework.ComparisonFailure: output is wrong expected:<[786432]> but
        at org.apache.hadoop.streaming.TestUlimit.runProgram
        at org.apache.hadoop.streaming.TestUlimit.testCommandLine

I have tried different values for ulimit on my RHEL 6.1 system on x86_64. I
also tried ant versions 1.8.2 as well as ant-1.7.1.

I would appreciate any ideas on what I might have setup incorrectly in my


Kumar Ravi

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message