hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bai Shen <baishen.li...@gmail.com>
Subject Re: User is not allowed to impersonate user1
Date Thu, 26 Jan 2012 16:42:17 GMT
Yes.  I need to do some debugging, so I'm trying to get hadoop compiled so
I can try some changes.

Also, I'm still getting the error even when running "mvn clean test".

I'm using the OpenJDK 1.6.0_22 on F16.  Is there any other information
needed?

On Thu, Jan 26, 2012 at 9:16 AM, Harsh J <harsh@cloudera.com> wrote:

> What are you looking to do exactly?
>
> Are you looking to compile and get the project setups ready for eclipse?
>
> On Thu, Jan 26, 2012 at 7:26 PM, Bai Shen <baishen.lists@gmail.com> wrote:
> > Ah, oops.  I forgot there was a dev list.  Sorry.
> >
> > I ran "mvn clean install -Pdist -Dtar -Ptest-patch" as directed in the
> > document.  I'm not sure what the options do, though.
> >
> > I'll give "mvn clean test" a try.
> >
> >
> > On Thu, Jan 26, 2012 at 7:07 AM, Harsh J <harsh@cloudera.com> wrote:
> >>
> >> Moving to common-dev@.
> >>
> >> I'm able to run all hadoop-hdfs-httpfs tests without failure if I do a
> >> "mvn clean test" under that directory.
> >>
> >> Can you try to clean and then re-run? Might have been a transient
> >> failure? Do you have the test logs?
> >>
> >> If you can reliably reproduce this test failure, please report with
> >> your environment (JVM make/version specifically), to the Apache JIRA
> >> under HDFS project.
> >>
> >> Note that if you want to build and go ahead with development without
> >> tests, pass "-DskipTests" to your maven commands.
> >>
> >> On Thu, Jan 26, 2012 at 3:02 AM, Bai Shen <baishen.lists@gmail.com>
> wrote:
> >> > I'm following the instructions in
> >> > http://wiki.apache.org/hadoop/HowToContribute to build the Hadoop
> trunk.
> >> > The build is failing the HttpFS tests with the above error.  "User is
> >> > not
> >> > allowed to impersonate user1."
> >> >
> >> > Googling doesn't seem to provide any useful results.  Is there
> something
> >> > I'm missing in the build configuration?
> >> >
> >> > Thanks.
> >>
> >>
> >>
> >> --
> >> Harsh J
> >> Customer Ops. Engineer, Cloudera
> >
> >
>
>
>
> --
> Harsh J
> Customer Ops. Engineer, Cloudera
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message