hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Harsh J <ha...@cloudera.com>
Subject Re: SVN Repo Question
Date Sat, 31 Dec 2011 03:25:18 GMT
Ronald,

On Sat, Dec 31, 2011 at 8:31 AM, Ronald Petty <ronald.petty@gmail.com> wrote:
> Harsh,
>
> Thank you for the information.  I still have a few more related questions:
>
>   - Does this mean only releases under "tags" are built using ant?  What
>   about the trunk (no build.xml in the root?)

All versions/branches/releases < 0.23 (Trunk is '0.24' in JIRAs) are
non-mavenized. 1.0 was a few weeks ago known as 0.20.2xx, so that is
non-maven as well. The plan is to rename 0.22 and 0.23 to such version
names too soon but until that happens this _will_ be confusing, yes.
Hope it is clear now?

>   - If I am going to attempt to contribute to Hadoop, do I check out
>   release-1.0.0 or trunk?  They appear to differ.  I presume 2.3/2.4/yarn is
>   the trunk and < 2.3 is the current releases of Hadoop?

You need to contribute all fixes to trunk first, and then backport to
older versions if absolutely critical/necessary and as applicable.

>
> Kindest regards.
>
> Ron
>
> On Fri, Dec 30, 2011 at 9:51 PM, Harsh J <harsh@cloudera.com> wrote:
>
>> Ronald,
>> On 31-Dec-2011, at 6:46 AM, Ronald Petty wrote:
>>
>> > Hello,
>> >
>> > Can someone explain the different layouts in the following repos,
>> > specifically regarding building from source?
>> >
>> >   - http://svn.apache.org/repos/asf/hadoop/common/trunk/
>> >   - http://svn.apache.org/repos/asf/hadoop/common/tags/release-1.0.0/
>> >
>> > I am still learning my way around the source and repo and noticed on
>> > http://wiki.apache.org/hadoop/HowToContribute it mentions you can build
>> src
>> > greater than .23 with Maven.  I am not sure how to do that for the 1.0
>> > release.
>> >
>> > Maybe a similar questions is, if I was going to build the 1.0 release
>> from
>> > source, is that the correct tag?  If so, what is the proper way to do it?
>>
>> Use a latest version of Apache Ant, and run the 'ant package' target. That
>> is the correct tag for the release, yes. Know, however, that 1.0 is a
>> rename of the 0.20 branch and is not a greater version over 0.23.
>>
>> >
>> > I have been able to build the trunk with Maven after a few tweaks.  It
>> > still seems to be missing a couple of items using -Pdist (conf directory
>> > and examples.)
>> >
>> > I appreciate the help.
>> >
>> > Kindest regards.
>> >
>> > Ron
>>
>>



-- 
Harsh J

Mime
View raw message