hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Payne <eric.payne1...@yahoo.com>
Subject Fw: Hadoop on Eclipse
Date Fri, 07 Oct 2011 14:09:04 GMT
I have been working in the 0.23 branch. Supposedly, there is not a lot of difference between
0.23 and 0.24.
 
I get the 'UNRESOLVED DEPENDENCIES' error sometimes, but then on the second try, it goes away.
Go figure.
 
I'm an eclipse newbie, but with a lot of help, I was able to get it going on the 0.23 branch
on Linux. Here's what I did:
 
-- from command line pull down the SVN repo:
export SVNROOT=http://svn.apache.org/repos/asf 
svn co $SVNROOT/hadoop/common/branches/branch-0.23
 
-- just to be safe, I remove my .m2 and .ivy directories from my home directory.
 
-- in 'branch-0.23' directory, use maven to build:
mvn clean install -Pdist -Dtar -DskipTests

-- in 'branch-0.23/hadoop-mapreduce-project' directory, build again:
mvn clean install assembly:assembly -DskipTests

-- In same directory, build using ant:
ant -Dresolvers=internal -Dcompile.c+=true -Dcompile.native=true -Dforrest.home=$FORREST_HOME
create-c++-configure tar  
    -- At this point, I do get the 'UNRESOLVED DEPENDENCIES' error. If I do, I just try
it again and it works.
 
-- start eclipse
-- I use the following maven plugin: http://m2eclipse.sonatype.org/sites/m2e
-- I go to the project explorer and choose to import a maven project and select the 'branch-0.23'
directory. It works for a while (10 minutes or so), and then you can edit, navigate, etc.
 
NOTE: I build from the command line, not from w/i eclipse.
 
Hope that helps.
-Eric
 
 
 
----- Forwarded Message -----
>From: Eric Payne <ericp@yahoo-inc.com>
>To: "eric.payne1000@yahoo.com" <eric.payne1000@yahoo.com>
>Sent: Friday, October 7, 2011 8:20 AM
>Subject: RE: Hadoop on Eclipse
>
>
>
>-----Original Message-----
>From: Tim Broberg [mailto:tbroberg@yahoo.com] 
>Sent: Thursday, October 06, 2011 11:00 PM
>To: common-dev@hadoop.apache.org
>Subject: Re: Hadoop on Eclipse
>
>After still more puttering, I gave up and just logged this in jira.
>
>https://issues.apache.org/jira/browse/HADOOP-7726
>
>    - Tim.
>
>
>
>
>________________________________
>From: Prasanth J <buckeye.prasanth@gmail.com>
>To: common-dev@hadoop.apache.org; Tim Broberg <tbroberg@yahoo.com>
>Sent: Thursday, October 6, 2011 11:02 AM
>Subject: Re: Hadoop on Eclipse
>
>Am also facing the exact issue. I think the documentation for setting up
>hadoop on eclipse is for older versions of hadoop. Now i am using hadoop
>0.24.0 snapshot and with reference to that the documentation seems outdated.
>Any help on this regard will be very useful.
>
>On Wed, Oct 5, 2011 at 10:34 PM, Tim Broberg <tbroberg@yahoo.com> wrote:
>
>> I am having issues similar to Alexandre's.
>>
>> The suggestion to run "mvn install -DskipTests -P-cbuild" clears up the
>> initial problems, but problems ensue...
>>
>>  1a - There is no hdfs subdirectory to change into.
>>  1b - If I instead cd to hadoop-hdfs-project and proceed, I get...
>>
>> [tbroberg@f15 hadoop-common]$ cd hadoop-hdfs-project/
>> [tbroberg@f15 hadoop-hdfs-project]$ ant compile eclipse
>> Buildfile: build.xml does not exist!
>> Build failed
>> [tbroberg@f15 hadoop-hdfs-project]$
>>
>>  2 - If I skip hdfs altogether and go to hadoop-mapreduce-project problems
>> much like the original issues crop up:
>>
>> Output is below, debug output is attached.
>>
>> Looks like maybe he's failing to expand ${yarn.version}?
>>
>> Anybody got any better suggestions than "go out to dinner?"
>>
>> Thanks,
>>    - Tim.
>>
>> [tbroberg@f15 hadoop-mapreduce-project]$ ant compile eclipse
>> Buildfile:
>> /home/tbroberg/workspace/git/hadoop-common/hadoop-mapreduce-project/build.xml
>> clover.setup:
>> clover.info:
>>      [echo]
>>      [echo]      Clover not found. Code coverage reports disabled.
>>      [echo]
>> clover:
>> ivy-download:
>>      [get] Getting:
>> http://repo2.maven.org/maven2/org/apache/ivy/ivy/2.2.0/ivy-2.2.0.jar
>>      [get] To:
>> /home/tbroberg/workspace/git/hadoop-common/hadoop-mapreduce-project/ivy/ivy-2.2.0.jar
>>      [get] Not modified - so not downloaded
>> ivy-init-dirs:
>> ivy-probe-antlib:
>> ivy-init-antlib:
>> ivy-init:
>> [ivy:configure] :: Ivy 2.2.0 - 20100923230623 ::
>> http://ant.apache.org/ivy/ ::
>> [ivy:configure] :: loading settings :: file =
>> /home/tbroberg/workspace/git/hadoop-common/hadoop-mapreduce-project/ivy/ivysettings.xml
>> ivy-resolve-common:
>> [ivy:resolve]
>> [ivy:resolve] :: problems summary ::
>> [ivy:resolve] :::: WARNINGS
>> [ivy:resolve]  io problem while parsing ivy file:
>> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn-server-common/0.24.0-SNAPSHOT/hadoop-yarn-server-common-0.24.0-20110914.035045-1.pom:
>> Impossible to load parent for
>> file:/home/tbroberg/.ivy2/cache/org.apache.hadoop/hadoop-yarn-server-common/ivy-0.24.0-SNAPSHOT.xml.original.
>> Parent=org.apache.hadoop#hadoop-yarn-server;${yarn.version}
>> [ivy:resolve]          module not found:
>> org.apache.hadoop#hadoop-yarn-server-common;0.24.0-SNAPSHOT
>> [ivy:resolve]  ==== apache-snapshot: tried
>> [ivy:resolve]
>> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn-server/${yarn.version}/hadoop-yarn-server-${yarn.version}.pom
>> [ivy:resolve]    -- artifact
>> org.apache.hadoop#hadoop-yarn-server;${yarn.version}!hadoop-yarn-server.jar:
>> [ivy:resolve]
>> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn-server/${yarn.version}/hadoop-yarn-server-${yarn.version}.jar
>> [ivy:resolve]  ==== maven2: tried
>> [ivy:resolve]
>> http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-yarn-server-common/0.24.0-SNAPSHOT/hadoop-yarn-server-common-0.24.0-SNAPSHOT.pom
>> [ivy:resolve]    -- artifact
>> org.apache.hadoop#hadoop-yarn-server-common;0.24.0-SNAPSHOT!hadoop-yarn-server-common.jar:
>> [ivy:resolve]
>> http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-yarn-server-common/0.24.0-SNAPSHOT/hadoop-yarn-server-common-0.24.0-SNAPSHOT.jar
>> [ivy:resolve]  io problem while parsing ivy file:
>> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-mapreduce-client-core/0.24.0-SNAPSHOT/hadoop-mapreduce-client-core-0.24.0-20110914.035126-1.pom:
>> Impossible to load parent for
>> file:/home/tbroberg/.ivy2/cache/org.apache.hadoop/hadoop-mapreduce-client-core/ivy-0.24.0-SNAPSHOT.xml.original.
>> Parent=org.apache.hadoop#hadoop-mapreduce-client;${hadoop-mapreduce.version}
>> [ivy:resolve]          module not found:
>> org.apache.hadoop#hadoop-mapreduce-client-core;0.24.0-SNAPSHOT
>> [ivy:resolve]  ==== apache-snapshot: tried
>> [ivy:resolve]
>> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-mapreduce-client/${hadoop-mapreduce.version}/hadoop-mapreduce-client-${hadoop-mapreduce.version}.pom
>> [ivy:resolve]    -- artifact
>> org.apache.hadoop#hadoop-mapreduce-client;${hadoop-mapreduce.version}!hadoop-mapreduce-client.jar:
>> [ivy:resolve]
>> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-mapreduce-client/${hadoop-mapreduce.version}/hadoop-mapreduce-client-${hadoop-mapreduce.version}.jar
>> [ivy:resolve]  ==== maven2: tried
>> [ivy:resolve]
>> http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-mapreduce-client-core/0.24.0-SNAPSHOT/hadoop-mapreduce-client-core-0.24.0-SNAPSHOT.pom
>> [ivy:resolve]    -- artifact
>> org.apache.hadoop#hadoop-mapreduce-client-core;0.24.0-SNAPSHOT!hadoop-mapreduce-client-core.jar:
>> [ivy:resolve]
>> http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-mapreduce-client-core/0.24.0-SNAPSHOT/hadoop-mapreduce-client-core-0.24.0-SNAPSHOT.jar
>> [ivy:resolve]  io problem while parsing ivy file:
>> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn-common/0.24.0-SNAPSHOT/hadoop-yarn-common-0.24.0-20110914.034958-1.pom:
>> Impossible to load parent for
>> file:/home/tbroberg/.ivy2/cache/org.apache.hadoop/hadoop-yarn-common/ivy-0.24.0-SNAPSHOT.xml.original.
>> Parent=org.apache.hadoop#hadoop-yarn;${yarn.version}
>> [ivy:resolve]          module not found:
>> org.apache.hadoop#hadoop-yarn-common;0.24.0-SNAPSHOT
>> [ivy:resolve]  ==== apache-snapshot: tried
>> [ivy:resolve]
>> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn/${yarn.version}/hadoop-yarn-${yarn.version}.pom
>> [ivy:resolve]    -- artifact
>> org.apache.hadoop#hadoop-yarn;${yarn.version}!hadoop-yarn.jar:
>> [ivy:resolve]
>> https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/hadoop-yarn/${yarn.version}/hadoop-yarn-${yarn.version}.jar
>> [ivy:resolve]  ==== maven2: tried
>> [ivy:resolve]
>> http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-yarn-common/0.24.0-SNAPSHOT/hadoop-yarn-common-0.24.0-SNAPSHOT.pom
>> [ivy:resolve]    -- artifact
>> org.apache.hadoop#hadoop-yarn-common;0.24.0-SNAPSHOT!hadoop-yarn-common.jar:
>> [ivy:resolve]
>> http://repo1.maven.org/maven2/org/apache/hadoop/hadoop-yarn-common/0.24.0-SNAPSHOT/hadoop-yarn-common-0.24.0-SNAPSHOT.jar
>> [ivy:resolve]          ::::::::::::::::::::::::::::::::::::::::::::::
>> [ivy:resolve]          ::          UNRESOLVED DEPENDENCIES        ::
>> [ivy:resolve]          ::::::::::::::::::::::::::::::::::::::::::::::
>> [ivy:resolve]          ::
>> org.apache.hadoop#hadoop-yarn-server-common;0.24.0-SNAPSHOT: not found
>> [ivy:resolve]          ::
>> org.apache.hadoop#hadoop-mapreduce-client-core;0.24.0-SNAPSHOT: not found
>> [ivy:resolve]          ::
>> org.apache.hadoop#hadoop-yarn-common;0.24.0-SNAPSHOT: not found
>> [ivy:resolve]          ::::::::::::::::::::::::::::::::::::::::::::::
>> [ivy:resolve]
>> [ivy:resolve] :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS
>> BUILD FAILED
>> /home/tbroberg/workspace/git/hadoop-common/hadoop-mapreduce-project/build.xml:2223:
>> impossible to resolve dependencies:
>>        resolve failed - see output for details
>> Total time: 23 seconds
>> [tbroberg@f15 hadoop-mapreduce-project]$
>>
>>
>
>
>
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message