hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eli Collins <...@cloudera.com>
Subject Re: JIRA attachments order
Date Fri, 09 Sep 2011 22:00:58 GMT
I updated HowToContribute, it people like this prose I'll advertise
the change to *-dev.

Thanks,
Eli

On Fri, Sep 9, 2011 at 2:53 PM, Eli Collins <eli@cloudera.com> wrote:
> On Fri, Sep 9, 2011 at 1:15 PM, Aaron T. Myers <atm@cloudera.com> wrote:
>> On Fri, Sep 9, 2011 at 12:57 PM, Eli Collins <eli@cloudera.com> wrote:
>>
>>> Patches for a specific branch should be named:  jira-xyz-branch.patch
>>> where "branch" may be abbreviated, eg hdfs-123-security.patch
>>>
>>
>> +1, if we ever hope to implement HADOOP-7435 [1], it will be necessary to
>> standardize the branch-name-in-patch-name scheme.
>>
>
> Good point.  One way to enforce this is for Jenkins to only run tests
> against patches that follow this naming scheme, and to put the actual
> branch name in the patch (where no branch means trunk). Ie
> xyz-123.patch will run against trunk, xyz-123-branchx.patch will run
> against branch x and all other patches will be ignored by Jenkins.
> Someone tedious eg for "branch-20-security" but means we dont have to
> maintain a mapping.
>
> Thanks,
> Eli
>
>
>
>> --
>> Aaron T. Myers
>> Software Engineer, Cloudera
>>
>> [1] https://issues.apache.org/jira/browse/HADOOP-7435
>>
>

Mime
View raw message