hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From abhishek sharma <absha...@usc.edu>
Subject Re: Namenode not starting
Date Thu, 01 Sep 2011 22:56:25 GMT
Actually, I found the reason. I am running HDFS as "root" and there is
a bug that has recently been fixed.

https://issues.apache.org/jira/browse/HDFS-1943

Thanks,
Abhishek

On Thu, Sep 1, 2011 at 6:25 PM, Ravi Prakash <ravihadoop@gmail.com> wrote:
> Hi Abhishek,
>
> Try reading through the shell scripts before postiing. They are short and
> simple enough and you should be able to debug them quite easily. I've seen
> the same error many times.
>
> Do you see JAVA_HOME set when you $ssh localhost?
>
> Also which command are you using to start the daemons?
>
> Fight on,
> Ravi
>
> On Thu, Sep 1, 2011 at 4:35 PM, abhishek sharma <absharma@usc.edu> wrote:
>
>> Hi Hailong,
>>
>> I have installed JDK and set JAVA_HOME correctly (as far as I know).
>>
>> Output of java -version is:
>> java version "1.6.0_04"
>> Java(TM) SE Runtime Environment (build 1.6.0_04-b12)
>> Java HotSpot(TM) Server VM (build 10.0-b19, mixed mode)
>>
>> I also have another version installed "1.6.0_27" but get same error with
>> it.
>>
>> Abhishek
>>
>> On Thu, Sep 1, 2011 at 4:00 PM, hailong.yang1115
>> <hailong.yang1115@gmail.com> wrote:
>> > Hi abhishek,
>> >
>> > Have you successfully installed java virtual machine like sun JDK before
>> running Hadoop? Or maybe you forget to configure the environment variable
>> JAVA_HOME? What is the output of the command 'java -version'?
>> >
>> > Regards
>> >
>> > Hailong
>> >
>> >
>> >
>> >
>> > ***********************************************
>> > * Hailong Yang, PhD. Candidate
>> > * Sino-German Joint Software Institute,
>> > * School of Computer Science&Engineering, Beihang University
>> > * Phone: (86-010)82315908
>> > * Email: hailong.yang1115@gmail.com
>> > * Address: G413, New Main Building in Beihang University,
>> > *              No.37 XueYuan Road,HaiDian District,
>> > *              Beijing,P.R.China,100191
>> > ***********************************************
>> >
>> > From: abhishek sharma
>> > Date: 2011-09-02 03:51
>> > To: common-user; common-dev
>> > Subject: Namenode not starting
>> > Hi all,
>> >
>> > I am trying to install Hadoop (release 0.20.203) on a machine with
>> CentOS.
>> >
>> > When I try to start HDFS, I get the following error.
>> >
>> > <machine-name>: Unrecognized option: -jvm
>> > <machine-name>: Could not create the Java virtual machine.
>> >
>> > Any idea what might be the problem?
>> >
>> > Thanks,
>> > Abhishek
>>
>

Mime
View raw message