hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rottinghuis, Joep" <jrottingh...@ebay.com>
Subject RE: Configuring Hadoop on eclipse
Date Sun, 04 Sep 2011 16:20:33 GMT
ArunKumar,

The guava error has nothing to do w. Eclipse.
The problem is an erroneous path that was applied and then later fixed on the 0.22 branch.
However the fix came in right when all the Jenkins servers were down.
The integration build that publishes the jar and pom for hadoop-hdfs has not yet run.

I noticed the same last week when trying to build HBase against 0.22, and have asked for a
committer w. access to run the build on jenkins or manually.
See HBASE-4327 and HDFS-2189.
I just opened the latter to focus attention on this.

Cheers,

Joep
________________________________________
From: ArunKumar [arunk786@gmail.com]
Sent: Sunday, September 04, 2011 12:43 AM
To: hadoop-dev@lucene.apache.org
Subject: Re: Configuring Hadoop on eclipse

Hi !

The problem is that some sites from where maven is downloading are blocked
by our proxy servers.
So i asked for an alternative.

However my quick fix question was :
" I am able to build hadoop source Project successfully using
http://tech.zhenhua.info/2010/11/svn-subclipse.html
http://tech.zhenhua.info/2010/11/svn-subclipse.html  but how do i run it in
eclipse so that i can see the working of Jobtracker,Tasktracker and namenode
in IDE."

I have used a direct internet connection (without proxy) to check out
whether what Harsh said was working for me or not.
-> ant compile eclipse was "BUILD SUCCESSFUL"  for "common" and "hdfs"
-> For mapreduce "ant compile eclipse" was giving :

[ivy:resolve] :: problems summary ::
[ivy:resolve] :::: WARNINGS
[ivy:resolve]           module not found: org.apache.hadoop#guava;r09
[ivy:resolve]   ==== apache-snapshot: tried
[ivy:resolve]
https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/guava/r09/guava-r09.pom
[ivy:resolve]     -- artifact org.apache.hadoop#guava;r09!guava.jar:
[ivy:resolve]
https://repository.apache.org/content/repositories/snapshots/org/apache/hadoop/guava/r09/guava-r09.jar
[ivy:resolve]   ==== maven2: tried
[ivy:resolve]
http://repo1.maven.org/maven2/org/apache/hadoop/guava/r09/guava-r09.pom
[ivy:resolve]     -- artifact org.apache.hadoop#guava;r09!guava.jar:
[ivy:resolve]
http://repo1.maven.org/maven2/org/apache/hadoop/guava/r09/guava-r09.jar
[ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve]           ::          UNRESOLVED DEPENDENCIES         ::
[ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve]           :: org.apache.hadoop#guava;r09: not found
[ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve]
[ivy:resolve] :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS

BUILD FAILED
/home/arun/git_mvn_eclipse/hadoop-common/mapreduce/build.xml:2147:
impossible to resolve dependencies:
        resolve failed - see output for details

Thank u very much .
Arun

--
View this message in context: http://lucene.472066.n3.nabble.com/Configuring-Hadoop-on-eclipse-tp3306402p3307993.html
Sent from the Hadoop lucene-dev mailing list archive at Nabble.com.

Mime
View raw message