hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eli Collins <...@cloudera.com>
Subject System tests on 0.20.20x releases
Date Sat, 20 Aug 2011 00:29:32 GMT
Has anyone tried running the system tests on a 0.20.20x release?  Why
don't we run these via Hudson?

After following the instructions on the wiki [1] and making a bunch of
additional fixes (setting dfs.datanode.ipc.address in the config,
using sbin instead of bin, copying libs into the FI build lib dir,
etc) I was able to get the tests running however the tests seem to
have bitrot.

The reason I ask is that it looks like the src/test/system tests are
only compiled or run via the test-system target and it doesn't look
like Hudson or developers use that target, therefore we're not doing
anything to prevent people from breaking the tests. I tried to run
them to see if one of my changes would break them but I can't imagine
most people will jump through all the above hoops.

On a related note, is there any way to run these against an existing
build/cluster? It looks like they require running on a build that's
been fault injected (ie they use custom protocol classes that are not
present in the normal tarball) which makes them much less useful.

Thanks,
Eli

1. http://wiki.apache.org/hadoop/HowToUseSystemTestFramework

Mime
View raw message