hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bill Graham <billgra...@gmail.com>
Subject Re: Chukwa setup issues
Date Fri, 01 Apr 2011 21:38:43 GMT
Moving over to chukwa list and letting common-dev fall off via bcc.

On Fri, Apr 1, 2011 at 2:37 PM, Bill Graham <billgraham@gmail.com> wrote:
> Unfortunately conf/collectors is used in two different ways in Chukwa,
> each with a different syntax. This should really be fixed.
>
> 1. The script that starts the collectors looks at it for a list of
> hostnames (no ports) to start collectors on. To start it just on one
> host, set it to localhost.
> 2. The agent looks at that file for the list of collectors to attempt
> to communicate with. In that case the format is a list of HTTP urls
> with ports of the collectors.
>
> Can you telnet to port 9999? It looks like it's listening, but
> nothing's being sent. Is there anything in logs/collector.log?
>
> On Fri, Apr 1, 2011 at 1:09 PM, bikash sharma <sharmabiks.07@gmail.com> wrote:
>> Hi,
>> I am trying to setup Chukwa for a 16-node Hadoop cluster.
>> I followed the admin guide -
>> http://incubator.apache.org/chukwa/docs/r0.4.0/admin.html#Agents
>> However, I ran two the following issues:
>> 1. What should be the collector port that needs to be specified in
>> conf/collectors file
>> 2. Am unable to see the collector running via web browser
>>
>> Am I missing something?
>>
>> Thanks in advance.
>>
>> -bikash
>>
>> p.s. - after i run collector, nothing happens
>> % bin/chukwa collector
>> 2011-04-01 16:07:16.410::INFO:  Logging to STDERR via
>> org.mortbay.log.StdErrLog
>> 2011-04-01 16:07:16.523::INFO:  jetty-6.1.11
>> 2011-04-01 16:07:17.707::INFO:  Started SelectChannelConnector@0.0.0.0:9999
>> started Chukwa http collector on port 9999
>>
>

Mime
View raw message